As the title says, I am unable to use a custom v3 address generated with mkp224o. My hidden service is in /var/lib/tor/nginx. The contents of the nginx folder: authorized_clients (folder) hostname hs_ed25519_public_key hs_ed25519_secret_key

I replaced the files in the nginx folder with the generated files and it didn't work as I was not able to connect and I restarted everything that was possible. After this, I deleted the whole nginx folder and rebooted everything. I updated the domain name in nginx and the website worked with a default generated address. Then I tried to delete everything in nginx and replace contents with the generated files. Still doesn't work. What do you think might be the issue? It's not related to nginx as I update the domain name and all the settings in the config.

  • This is not an application that the Tor Project created. It is a program that a third party wrote. I would suggest putting in an issue with the developer directly. github.com/cathugger/mkp224o
    – elmerjfudd
    Commented Mar 21, 2020 at 16:43
  • Not a pretty answer but some checkout points: 1) check the output of tor: do not use tor daemon. but use as a command line application. 2) wait for HSDirs to be updated. They may be the cause of the problem. Hope it helps.
    – Mir Saman
    Commented Mar 22, 2020 at 22:31

1 Answer 1


Late Answer!

It may be a permission problem. Tor itself accepts Read,Write,Execute only with debian-tor user. Maybe the user is the owner of the files that are generated by mkp224o, not debian-tor. So you may change the permission to 700 and the owner to debian-tor:

$ sudo chmod 700 -R /var/lib/tor/*
$ sudo chown -R debian-tor /var/lib/tor/*
$ sudo service tor restart

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .