0

i have Debian 10 installed so i install tor and edit the torrc file:

HiddenServiceDir /var/lib/tor/hidden_service/

HiddenServicePort 80 127.0.0.1:80

but it did not work out because hidden_service folder was not created... so i give read and write permission to /var/lib/tor folder and it works, url was generated with private and public keys...

then i just start apache via sudo service apache start

localhost was perfectly worked but in tor browser when i browse the generated onion url it could not connect to web server why?

the same thing was with Nginx too

can someone tell me what i am doing wrong?

0

Here are some troubleshooting ideas:

stop the tor systemd service:

sudo systemctl stop tor

run tor manually to see if there are any errors that systemd is not reporting.

tor -f /etc/tor/torrc

If you are not getting an errors and ff you are still not able to connect with Tor Browser, try changing your route. Remember, it takes time for your new onion service to propagate. When I experiment with this, I know that it can take 5+ minutes for a "live" site to be be available. I've even had 10+ minute wait time before.

There is no ping with tor to see if something is working but you can do this:

watch 'torsocks curl youronionsite.onion'

It will attempt connect every 2 seconds and you will see when it comes live.

| improve this answer | |
  • tor -f /etc/tor/torrc Feb 26 22:59:44.018 [notice] Read configuration file "/etc/tor/torrc". Feb 26 22:59:44.019 [warn] Directory /var/lib/tor/hidden_service/ cannot be read: Permission denied Feb 26 22:59:44.019 [warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details. Feb 26 22:59:44.019 [err] Reading config failed--see warnings above. ... i give all the permissions to that folder "read and write" still the same error – karencho Feb 26 at 19:11
  • sudo chown tor -R /var/lib/tor/hidden_service/ and sudo chmod 700 -R /var/lib/tor/hidden_service/ – JSEvans Feb 26 at 19:22
  • sudo chown tor -R /var/lib/tor/hidden_service/ chown: invalid user: ‘tor’ ... then i have tried for debian-tor user, but the outcome the same no connection – karencho Feb 27 at 4:11
  • so no one can help? – karencho Feb 29 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.