5

I have generated a custom onion hostname and key using eschalot. Tor will run fine on the default hostname (the one Tor generated itself), but not with my custom domain.

The problem is with the permissions in /var/lib/tor/hidden_service/ For this example, ../hidden_service/ has this structure

hidden_service
  -folder2    <(contains custom key&name)
   hostname
   private_key  

hostname & private_key in the top directory will serve a site with no hiccups, however, after editing my torrc to point to folder2, tor returns the following permission error:

Nov 29 09:57:52.997 [warn] Permissions on directory /var/lib/tor/hidden_service/folder2 are too permissive.
Nov 29 09:57:52.997 [warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details.
Nov 29 09:57:52.997 [err] Reading config failed--see warnings above.

I have chmod'ed the directory to every possible combination I could imagine would apply, I've chown'ed the directory with and without -R to debian-tor:debian-tor.

I'm running Ubuntu 14.04.3

NOTE: I've been searching and though there are similar questions, most users self fixed without explanation.

2

I don't know if it is strictly necessary, for me it works with these permissions:

700 (or drwx------) for the folder (folder2 in your case)
600 (or -rw-------) for the private_key file.

Both owned by the user and group that runs the tor process.

  • I've been working on this for a few hours and this was such a simple fix, thank you so much! – jpl42 Nov 29 '15 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.