2

I would like to set exit node from within tails by using the command line. I am currently using tails live CD. I tried to do this by saving in torrc but it won't save. I though it might store in RAM, but it does not. I tried command line ExitNodes{US}. It gave out this bash:ExitNodes{US}: command not found. Can I do this. If so how? What do I type in terminal?

2

The preferred way should be to put it into your torrc. You wrote in your question, that you couldn't save the file. Did you maybe edit it as the wrong user? Usually you need superuser rights (sudo).

If you want to pass the option on the command line, you could do the following:

tor --ExitNodes "{us}"

You need to put {us} insides quotes, because otherwise your shell will interpret it in a different way. Another way to realise it is to use backslashes:

tor --ExitNodes \{us\}

You can also use echo to write into your torrc:

echo ExitNodes "{us}" | sudo tee -a /etc/tor/torrc

This command appends the line ExitNodes {us} to your torrc.

  • I am getting this error form command line and can not connect to the net. As to the etc/tor/torrc file configuration it says read only and can not save it. May be this is because I am using live CD. Any thing I can do about command line? amnesia@amnesia:~$ tor --ExitNodes "{US}" Oct 08 04:00:49.203 [notice] Tor v0.2.6.9 (git-145b2587d1269af4) running on Linux with Libevent 2.0.19-stable, OpenSSL 1.0.1e and Zlib 1.2.7. Oct 08 04:00:49.203 [notice] Tor can't help you if you use it wrong! Learn how to be safe at torproject.org/download/download#warning Oct 08 04:00:49.203 [notice] Rea – Silver Oct 14 '15 at 11:06
  • Take a look at my answer above. Too long ot include in comments – Silver Oct 14 '15 at 11:11
  • Could you try the following command: 》echo ExitNodes "{us}" | sudo tee -a /etc/tor/torrc《? What happens? – Jens Kubieziel Oct 14 '15 at 11:32
  • Thanx it works with this echo command – Silver Oct 15 '15 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.