4

The last two versions of Tor Browser that I have tried on Mac OS are still OK for the admin account but when I try to launch in my normal user account, I get

Tor Browser does not have permission to access the profile.
Please adjust your file system permissions and try again.

Thinking it could be related to my adding a line to torrc, I chmod that to 777 but it didn't help. I ran fs_usage(1) to try to figure out what files it was hitting, but there are zillions of output lines per millisecond. I did see that it was hitting files in ..../TorBrowser.app/TorBrowser/Data/Browser/profile* so I changed the group on all of those. Still doesn't work (and none of the files I just changed group on have ever been touched by me before).

Knowing that the Tor Browser is derived from FireFox, I deleted the app completely, along with a file elsewhere that had "torproject" as part of its filename, and deleted my entire ~/Library/Application Support/Firefox directory (which contains the FireFox profile). Installed a freshly downloaded copy of the Tor Browser and tried again. Same error.

So I'm puzzled....

  • 1
    It's possible you've unzipped/installed the Tor directory to an area of the file system that only admin users have access to. What's the full path to your directory? (i.e. What's does the "...." at the start of the path represent?) – Richard Horrocks Jul 26 '15 at 7:54
  • It's where I put all the apps that didn't come from Apple. O.O. was in the exact same path when it was working, and other apps there still work. – WGroleau Jul 29 '15 at 11:03
  • Sorry, not O.O. but TorBrowser. – WGroleau Jul 29 '15 at 11:09
  • I got this error when installing with Chocolatey: chocolatey.org/packages/tor-browser – user598527 Aug 27 '16 at 19:53
3

I think this will be a general ownership problem.

I'm suspecting that you downloaded the DMG file, and unpacked it, as the admin user. To run as a normal user, you'll need to download and unpack it using that user's account.

The reason for this is that only the owner of the file can write to the profile (because it is their profile).

The 'profile' is in TorBrowser.app/TorBrowser/Data/Browser but 'chown' and 'chmod' on those files/directories will not solve the problem. Not sure why, but these only introduce weirder errors. Each tor user will have to have his or her own copy of the application.

UPDATE: As has been stated elsewhere, "Each tor user will have to have his or her own copy" was a poor design decision (or more likely, something not considered). But I say was because 6.0 resolves that issue. TBB on Mac now looks for the user's profile in a directory under ~/Library/Application\ Support (and creates it if necessary).

  • I am not trying to run it from the DMG. It is in the same place as 272 other apps that have no permissions problems. Also, earlier versions did not have this problem. And /Applications is not a "read-only file system." – WGroleau Aug 29 '15 at 3:43
  • Also, that bug is shown as closed five months ago. This problem started much less than five months ago. And what in the Sam Hill is the rationale for a single profile for all instances of an app on a multi-user operating system? – WGroleau Aug 29 '15 at 3:48
  • Also, "chown-ing the relevant directory" does not "identify what file needs what permissions to remove the error." Did you mean chmod ? 'chown,' if it did anything at all, would move the problem to all other users. – WGroleau Aug 29 '15 at 3:52
  • Are you extracting the DMG and then copying to the /Applications directory, or copying the DMG to the /Applications directory and opening it there? – Richard Horrocks Aug 29 '15 at 7:24
  • I open the DMG and copy the application. Any other method is not only ineffective but more work. Same way I do any app that doesn't have an installer. I already said I'm not trying to run it from the DMG. I tried the advice for installing it in the non-admin directory owned by the non-admin account. It works that way. So apparently it is a general ownership problem--a silly design change done mid-July. Silly because it means that an admin has to install and update a separate copy for every user on every machine. So, with slight edits, I will relax my demand and accept that answer. – WGroleau Aug 30 '15 at 2:15
0

I found a solution; a weird one though!

  1. Option-Drag the TorBrowser application from the Application folder to the Desktop.
  2. Remove the TorBrowser application from the Application folder
  3. Option-Drag the TorBrowser application from the desktop back to the Application folder

Don't know why it worked but, for me, it did!

(Note: I actually duplicated the TorBrowser application inside the Application folder before option-dragging the copy to the desktop. I then renamed it back to it's original name and then, after deleting both applications (original and copy) in the Applications folder, I dragged it back. I don't think these extra steps are required though.)

  • 1
    By doing this, you probably changed some of the file attributes inside the app bundle. Probably the app will no longer work for other user accounts. – WGroleau Nov 8 '15 at 23:02
-1

Simply right click on "Start Tor Browser". From the list that follows, click on "Run as Administrator". This should work.

  • 1
    Mac OS has never had a "Run as Administrator" and the TBB when running does not have a "Start Tor Browser." If it did, it wouldn't help get the TBB to run. – WGroleau Dec 18 '15 at 18:57

protected by Community Jul 29 '16 at 18:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.