2

I've done some looking for my problem and I've learned a bit but still get the same result. The "result" is when I uncomment my hidden service lines in my torrc, tor will not start and not produce any logs. When I comment them all is good.

Initially I was using just the browser, trying to start a hidden service there. I read an article from someone having similar experiences and went to #tor channel on irc. They went to https://www.torproject.org/docs/debian.html.en and installed the tor package. I did too. I chose option 2.

I already downloaded apache2, php5 and mysql. I followed instructions to make each more secure. I have a test web page. In my tor browser after disabling the proxy for 127.0.0.1 I can view my webpage.

Once I had it installed I then proceeded to https://www.torproject.org/docs/tor-hidden-service.html.en . Where I have already been trying to configure my browser. I was on IRC earlier tonight but no one could help. We went over things more thoroughly... the only thing I can think of is permissions but am not sure.

Versions

Ubuntu 14.04
Tor v0.2.7.6
Libevent 2.0.21
OpenSSL 1.0.1f
Zlib 1.2.8

File Ownership

/var/lib/tor/hidden_service (drwx--S---) - debian-tor:debian-tor

/var/lib/tor/hidden_service/srv (drwxr-s---) - debian-tor:debian-tor

/etc/tor/torrc (-rw-r--r--) - root:root

I'm unsure what the difference between the upper- and lowercase S is. Or why srv has group read. (Might've been something I did just don't remember.)

I'm not a member of the debian-tor group.

Starting/Stopping

sudo service tor [start|stop|restart]

Config files

Without my attempt to run a hidden service they are unchanged. To run a hidden service I uncommented the lines in the /etc/tor/torrc file and changed them to read:

HiddenServiceDir /var/lib/tor/hidden_service/srv
HiddenServicePort 80 127.0.0.1:80

That was my only change.

Output

Restarting the daemon with the original torrc file I get two lines:

 * Stopping tor daemon...                   [OK]
 * Starting tor daemon...                   [OK]

Uncommenting the hidden service lines and restarting I get:

 * Checking if your tor configuration is valid
<date> [notice] Tor v0.2.7.6 running on Linux with Libevent 2.0... blah blah
<date> [notice] Tor can't help you if you use it wrong... blah blah
<date> [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
<date> [notice] Read configuration file "/etc/tor/torrc".
<date> [warn] Permissions on directory/var/lib/tor/hidden_service/srv are too permissive.
<date> [warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details.
<date> [err] Reading config failed--see warnings above.

The thing is if I remove my log file and restart with hidden services enabled... I get no log. However as soon as I recomment the lines and restart I now have a log file.

What am I missing?

1

Try unsetting the setgid bit on your directories.

You're aiming for permissions of either 600 or 700. The setgid bit is presumably a security concern as it indicates other users might have execute permissions on someone else's files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.