3

From Section 2.2 of the path specification

We do not choose any router in the same family as another in the same path. (Two routers are in the same family if each one lists the other in the "family" entries of its descriptor.)

On more than one occasion I've had to manually create a NodeFamily from the results of Atlas. In each case the node has a family but appears to ignore it during path selection. That is, until I create the family manually. This occurs with StrictNodes using Tor v0.2.5.10.

In a related incident, despite the use of StrictNodes, an exit was used which violated constraints put into effect. Now I can understand being flexible in choosing to violate (some) constraints. If I say I don't want an exit to be used and I use StrictNodes, then the exit shouldn't be used.

Should I be concerned or is there a good reason for this to occur?

  • Dear Leeroy, The link [3] points to content of link [2], Thus to "NodeFamily node,node,..." not to "StrictNodes 0|1". Warm Regards – Roya Jan 11 '15 at 17:06
  • Oh thanks! I guess editing others comments became taboo while I was away. I shall have to remember that ;P – user5341 Jan 17 '15 at 23:53
1

Based on setting strict nodes and having an exit show up which violates this constraint I would (now) be inclined to search for a bug. Had just the family constraint been violated I might see this as a situation where Tor decided to default on path selection. That does occur -- it just seemed extreme to ignore node family. On the other hand, ignoring the node family isn't a huge deal. These nodes are precisely the ones that put the effort into identifying their relations. I'd be more worried about unidentified relations.

Combined the two issues point to a bug which should be reproduced.

I didn't see an existing ticket so I'll start by writing some code to investigate the problem over time. Then I can reproduce the problem or at least inspect the internal state at the time of failure. As it stands this doesn't appear to occur frequently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy