2

How do I see all the scripts in the permission contextual menu so that I can allow only specific scripts?

I upgraded to the newest tor browser version 4.

With earlier tor versions, I would go to a page and I could enable or disable each individual script. I always disable scripts globally and then temporarily allow only the scripts I want.

Now, I only have one option for the specific site I visit. I often go to sites that have other scripts that I do NOT want to allow (like scripts from facebook or twitter).

To clarify, the version of NoScript is the same between tor browser versions. I have gone through and checked all NoScript settings to make sure they're the same, but the scripts still don't show up in the permissions menu.

1

I figured it out.

Open the NoScript options.
Go to Advanced Tab. Click on 'Trusted' sub tab.

Deselect / uncheck option that says: Cascade top document's permissions to 3rd party scripts.

Now all scripts show up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.