I recently updated Tor Browser and now I can't permanently allow javascript through the NoScript menu. All I see in it is "Temporarily allow all this page" and options to disable already enabled sites. If I want to enable it on the current site, I have to permanently enable all the page and then disable what I don't want, and these exceptions are not stored permanently. Plus it is time consuming. Why did the original options disappear? How can I easily enable javascript for websites like before?

  • 1
    The TorBrowser ships with NoScript which is configured to allow JavaScript (globally) by default. By default the menu should say "Forbid Scripts Globally", as JS is not blocked.
    – bastik
    Jan 1, 2014 at 13:19

1 Answer 1


As users with different JavaScript settings are easier to fingerprint it would seem to make sense to limit the number of sets someone can fall into.

Ideally JavaScript would be either on or off, whereas off would be the best possible solution if not so many websites would require JavaScript to work. The reason for it being on by default is just that.

If you temporarily allow something for the session it won't bite you back if someone inspects your computer with the TorBrowser on it as he is unable to tell if you visited a website and had JavaScript enabled or not. If you allow it permanent it might do just that, it bites you.

Since it is possible to tell users apart that allow JavaScript for a combination from x), y) or z), there will be no difference these users if the all allow scripts from x, y and z.

From a support point of view it also makes sense to enable all scripts on a website temporarily, since there are websites that run scripts from y) and also require scripts from z) to function properly.

Less anonymity issues, less support issues. Maybe easier to handle by users.

Arguably one can say that it is dangerous to run all scripts a website would like. Arguably one can say that not all scripts are required.

Since this are valid statements you can (re-)enable the entries you want.

NoScript Options > [Appearance] > Show...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .