1

I'm stuck in a loop of "Sorry. We just need to do one small thing to keep going." and restarts.
I have spent hours on this and my seach-fu is not bad, bu to no avail.

Restart Required

It happened first after an update, and then with a fresh download of tor-browser-linux64-9.0.5_en-US.tar.xz. (I'm on Ubuntu 18.04) Help->About->version shows as up to date.

starting with the --verbose or --log flag puts out about 130 lines of messages with lots of warnings and errors, but I have no idea how many of these are just the usual "firefox-noise". I have searched for a lot of them and gone down a number of rabbitholes but ultimately came up empty handed.

I have also inspected the start-tor-browser script and tried to start the browser in different ways like running firefox.real, but nothing makes any difference to the behavior. (except if I break DISPLAY)

My current theory is that something makes an internal process crash and that is detected as if an external system has updated it's files.

I'd be happy to upload the log, but I understand that pestebin etc. is frowned upon.

Any help is appreciated.


For the record: Since I wrote the above, an OS update, a reboot and a browser update has happened and the issue just went away. I guess we'll never know exactly what caused it.

What I can report is where the failing and successful logs diverge.

Failing:

Mar 11 07:59:58.000 [notice] Bootstrapped 100% (done): Done
Unable to init server: Could not connect: Connection refused

(/home/user/tmp/tor-browser_en-US/Browser/firefox.real:2985): Gtk-WARNING **: 07:59:59.408: cannot open display: :0
[Parent 2921, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /var/tmp/build/firefox-869854aeea80/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 727
[Parent 2921, Gecko_IOThread] WARNING: FileDescriptorSet destroyed with unconsumed descriptors: file /var/tmp/build/firefox-869854aeea80/ipc/chromium/src/chrome/common/file_descriptor_set_posix.cc, line 23

Working:

Mar 23 08:05:21.000 [notice] Bootstrapped 100% (done): Done
Mar 23 08:05:21.000 [notice] New control connection opened from 127.0.0.1.
Mar 23 08:05:21.000 [notice] New control connection opened from 127.0.0.1.
Fontconfig warning: "/home/user/tmp/tor-browser_en-US/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 145: blank doesn't take any effect anymore. please remove it from your fonts.conf

I would say this strongly point to an issue with "display" but I tried dozens of things with that, so who knows.

  • I would personally delete it and any configuration files and start fresh, but if you have bookmarks or other things, I understand why you might be hesitant to do that. My suggestion is to open a bug on trac.torproject.org and then paste the link here. That way people can see the logs and also the developers can be aware of it. Make sure to remove an IP addresses or other personal information that might be there first. – JSEvans Mar 13 at 13:45
  • I have deleted the tor-browser_en-US folder several times and re-extracted it and started fresh from different locations without that making any difference. Clearly something in the larger OS is causing trouble. I considered trying out a chroot jail, but this is really starting to feel like shaving yaks! Yes I suppose Track is the next step :-/ – user28811 Mar 13 at 19:51
  • One more thing, create a temporary second user, install Tor Browser on their profile, and see if it still happens. This will tell you if there is an issue with your config or if there is something wrong with the OS as a whole. – JSEvans Mar 13 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy