3

Since a few days ago, can't pinpoint the date, .mp4 links fail to open; .webm play fine. These are links to straight .mp4 files, not through custom players, or anything, and they did play before with the browser's native player. Now, opening them in a new tab, instead of a tab with the NoScript block waiting to be unlocked, all there is is an empty tab, as if there's not even a canvas; it's only the window colour (as defined in the window manager). BTW, this is Tor browser 10.0.10 in Archlinux x64 (official archive). The settings are set to no javascript, safest level (except when it's really needed, like now, when it's on "safer"), plus various other settings found on privacytools.io.

This is how it looks like when opening a new tab, normally:

normal

and this is when I try to open a link:

now

The media should still be blocked by NoScript, the overlay should have appeared, but there isn't. I notice there is traffic going on, the browser tries to buffer something, but nothing happens. I tried searching through about:config, but there doesn't seem to be anything out of the ordinary. The NoScript extension shows it has been updated "Feb 4th", so around the time when TB had an update, (more or less).

Does this happen because of the TB or the NoScript? But, more importantly, what can be done to fix it?

In addition, there are sites that don't display correctly, anymore. One of the is github. I can post screenshots, if needed. And the scrollbar now, when clicked, it doesn't scroll page by page, instead it goes where the mouse clicked. This is not how the desktop environment behaves (Xfce).


Minor update: searching for browser test pages, I found this. Towards the middle of the page there is a section Diagnostic Videos. Opening the mp4 link displays this:

nothing

Nothing plays. The other media links are opened normally, with NoScript overlay which, removed, allows normal playback. Firefox has no problems.

Given Steve's comment below (and the reply), there may be a possibility that my system is lacking something. So what codecs does TB use and how can I check for those in my system?

4
  • On Ubuntu with 10.0.10 the URL works for me on the "Safest" setting (the NoScript overlay appears, I click accept, and the video plays). Can you try downloading a fresh copy of Tor Browser with no configuration changes and check if it plays the video? – Steve Feb 12 at 15:55
  • @Steve It doesn't work. Now I'm worried. I checked .pacman -Qs ffmpeg and it shows there is ffmpeg and gst-libav, so there should be codecs? Or is TB using something else? – a concerned citizen Feb 12 at 16:19
  • I'm not sure. Does it work in Firefox? If it worked on a previous version but doesn't on a fresh installed latest version, then I would recommend making a bug report here: gitlab.torproject.org/tpo/applications/tor-browser/-/issues – Steve Feb 12 at 16:38
  • 1
    @Steve It works on Firefox. Thank you for the link, but if it works for you and we're using the same archive/version then I'm a bit reluctant to use the bug report, at least until I determine whether it's my system, or not. – a concerned citizen Feb 12 at 17:26
1

The newest update to 10.0.13 corrected this behaviour.

Unfortunately, NoScript still doesn't set javascript.enabled to true when setting the security to "safer", manual setting is needed through about:config (and when going back to "safest"). But that's a minor inconvenience, possibly safer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.