5

I recently decided to pay for CryptoStorm anonymous VPN as an extra layer to my privacy protection - so that all requests including UDP requests are automatically masked. As I understand it, all traffic through the VPN is routed through the Tor network as well.

So I don't think it's necessary for me to be additionally running Tor locally (correct me if I'm misunderstanding something here).

However, I would still like to use the Tor browser, as it takes care of many other security concerns - like protection from WebRTC detection and other JavaScript-based vulnerabilities.

Is there any way to run the Tor browser without proxying through Tor? I tried setting "No proxy" in the network settings, but it just says "Unable to find the proxy server" - suggesting the browser is hard-wired to run through the Tor proxy.

Or if it isn't possible to connect directly with TBB, is there another browser (probably another fork of Firefox) which would cover all the same client-side security concerns?

4

You have to disable Torbutton.

At the top of the connection settings dialog, it indicates this: "Disable Torbutton to change these settings."

In about:addons you can disable Torbutton and TorLauncher and then quit/relaunch the browser. Then you can set your own proxy settings or none in the network connection settings.

Edit to add: If you don't use a proxy, you must also disable Remote DNS in network connection settings. Even thought it is greyed out when No Proxy is selected, it must be unchecked.

Edit: Better and more complete instructions:

  1. Type in about:addons in the URL bar.

  2. In that page, disable Torbutton and TorLauncher add-ons.

  3. Restart the browser as prompted.

  4. Click on Menu (3 horizontal bars logo located at top-left) > Preferences/Options > Advance vertical tab > Network horizontal tab.

  5. Click on the Settings button on the right of "Connection" label (while you are in that tab) which opens up the proxy configuration window.

  6. Untick Remote DNS checkbox (At center-right of the window).

  7. Change your proxy settings accordingly to your own proxy or to no proxy and click OK.

  8. Congratulations have de-torified the Tor browser!

  • I missed that! Unfortunately, I just tried this and it still doesn't work. I disabled Torbutton and TorLauncher, restarted the browser, then set "no proxy", but I still get "Unable to find the proxy server". I also tried "Auto-detect..." and "Use system...", but to no avail. Am I missing a step? – Robin Winslow Nov 5 '15 at 18:30
  • 2
    I've tested back and forth a bit and it's weird. I now think that Remote DNS must also be disabled. Even tho it is greyed out when No Proxy is selected, it must be unchecked. So it seems... – Jobiwan Nov 5 '15 at 18:51
  • @Joblwan BOOM! It works! Thanks you :) Could you add the extre remote DNS step to your answer? – Robin Winslow Nov 6 '15 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.