0

I have a executable .jar file which I want to execute. It needs internet access, but it seems like it is the only program wich is not able to access the internet. I use the standard configuration for the JRE which comes preinstalled on tails (openjdk-7-jre). I suppose this is a problem with the JRE configuration but I was not able to find a way to change it in a way that would make it work. Do you have any idea what I can do?

  • Have you tried just wrapping it in torsocks? It can cause problems with some applications but it may serve your purposes. – cacahuatl Jan 12 '17 at 22:24
0

First of all, try Oracle JDK/JRE - OpenJDK causes such a weird problems sometimes even nowdays. Second - try to use Tor as a proxy, set these properties:

  • java.net.useSystemProxies=true
  • http.proxyHost=proxy-ip
  • http.proxyPort=proxy-port
  • Where do I set these props? In the jcontrol file? – user6287736 Jan 12 '17 at 20:52
  • or in the command line switches – Alexey Vesnin Jan 12 '17 at 20:58
  • it says "unrecognised option: java.net.useSystemProxies=true". Same with the other 2 properties – user6287736 Jan 12 '17 at 21:42
  • you have to use -Dproperty=value , see the official docs for details, it's here – Alexey Vesnin Jan 12 '17 at 21:43
  • ok the properties are set now, thanks. Still it doesnt work. I am probably using the wrong ip and port. I'll try it again tomorrow – user6287736 Jan 12 '17 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.