1

I am trying to get the Grugq's P.O.R.T.A.L. to work. So far I have tried it on a router TP-Link TL-WR703N and a Raspberry Pi with Arch Linux installed.

The networking part is what confuses me. I am not sure what to do. I have PORTAL on both devices but I cannot find any tutorials or information on how to set it up to route my connections through Tor.

1

Well, the main problem is that the hardware you are using will not support the grugq's image. According to the specs here

The hardware only has 4mb flash memory, and to run Tor alone you will need at least half a meg of binaries. Thats the reason most commercial routers will not run Tor even with firmware changes. Arch linux is an unusual choice for host OS, but the raspberry should have resources to support it. If you are willing to use openwrt, there is a good tutorial on the Tor project site:

to hardware router

There is a tutorial for running it based on debian also but not one for arch. Installing openwrt will probably get you up and running the fastest. You can just login by ssh and update the package manager #opkg update install Tor (might as well try the alpha versions)

#opkg install tor-alpha 

The login and overwrite your /etc directory with premade config files: vanilla tor router /etc directory

0

I too have the WR703N and if you actually read the grugq's specs it is recommended as the ideal device as long as it has the Ram and Flash mod to double them. You can buy these moded versions on ebay for around £30. Additionally you can still use the stock WR703N as long as you use an external USB stick to act as extral storage with the firmware libraries rooted to the usb stick. Admittedly the grugq does say that the stock version may experience some peformance issues compared to the modified WR703N.

I have the modified version and am having the same problems as the OP. Did you manage to solve them? Put simply I have three listed interfaces. 1) Admin (Eth0) 2) Internet (Eth1) 3) Tor (Wlan).

I would ultimately like the option of being able to switch my access from wireless to ethernet in different situations but in this instance would be grateful for any Tor connection at all. I have scanned using wifi in the admin interface and connected to my home wifi network. I have connected my computer by ethernet to the wr703n. The Admin interface seems always connected by default. I try turning my computer wifi off connecting to the wr703 by ethernet with both static and then dhcp but still no Tor connection (or internet connection through the device). I am convinced that altering the interfaces is the answer but could really do with some help. Has anyone out there managed to get any further forward (or did you find anyone who did)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.