4

Since today I've got a very strange warning in my log files:

Sep 19 23:16:48.372 [Warning] Received http status code 404 ("Consensus not signed by sufficient number of requested authorities") from server '212.112.245.170:80' while fetching consensus directory.

I receive this warning after I tried to switch my OR and Dir ports to 80 and 443 (which failed) to warrant accessibility for clients that are restricted through a firewall that blocks other ports.

My OS: Windows Server 2012 R2 Enterprise Tor platform: Vidalia relay bundle

The question now is: Does it affect my relay in any way of and if this warning can be solved, how?

I would appreciate any tips or hints on this.

  • 1
    I had a look on the bug tracker at the Tor Project and there seems to be a number of similar reports concerning ("Consensus not signed by sufficient number of requested authorities") warnings, including outdated versions of Tor and firewall configuration. So that others may be able to offer more detailed suggestions, you should post the full error log and firewall warnings (with Linux; tail -f /var/log/syslog) and perhaps torrc configuration. – simulacrum Sep 21 '14 at 6:05
  • So I watched my log on weekend and it's everytime the same IP that is giving my node an 404 status code. But in the last 36 hours there were no problems so far. – DerTorSteher Sep 22 '14 at 6:06
  • Seems like a temporary problem. Maybe there was a problem in my AS or on the side of the authority node. Everything fine by now. :) – DerTorSteher Sep 23 '14 at 6:29
1

The operator of the directory authority gabelmoo recently moved the server to a new IP address. According to bug report #13199 he screwed up the configuration. However this is fixed now and the warning in your log should disappear.

  • 1
    Thank you very much :) This warning never appeared again since ~60h. Everything works as intended now. – DerTorSteher Sep 23 '14 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.