4

I was surprised to find this hadn't been asked already.

In ../Browser/TorBrowser/Data/Tor/torrc-defaults I tried changing SocksPort/ControlPort from 9150/9051 to 9170/9071. Then changed the SOCKS port in the browser Preferences >> Advanced >> Network >> Settings....

This didn't seem to work. The tor browser stalls when trying to open it.

Is it possible to change the default tbb ports? If so, how to?

Thanks!!

Ubuntu 16 with TBB 6.5

3

The easiest way to define them is through use of environment variables, e.g. start Tor Browser with the command, e.g.:

env TOR_SOCKS_PORT=9170 TOR_CONTROL_PORT=9071 ./Browser/start-tor-browser

or by setting them in your default profile, e.g. creating a file called /etc/profile.d/z-torbrowser.sh containing the lines:

export TOR_SOCKS_PORT=9170
export TOR_CONTROL_PORT=9071

These environment variables are checked by the Tor Launcher and Tor Button extensions and if they are defined, they override the defaults.

Alternatively...

The more complicated approach and involves editing setting under about:config, specifically these:

extensions.torlauncher.control_port=9071
extensions.torbutton.custom.socks_port=9170
network.proxy.socks_port=9170

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.