4

First of all I am kind of new to Linux and Ubuntu, also I have not been using tor for long, I am learning about it. It is the first time I encounter issues with it, been using on Win and Ubuntu fine until now.

Cutting things short, I cannot start Tor browser through any means. I have searched tor stack exchange and did not found a solution that works for me, having this problem for a few days now. It worked before on my Ubuntu 16.04 LTS.

Done System updates. Tor is up to date. Removed and reinstalled Tor. Tor was installed with apt-get install tor.

Things I have tried:

  1. Starting it by GUI (icon), what happens is that it flashes for a few times but it does not start. Tried to start it with firefox closed as suggested in a post I do not remember where, same thing.

  2. Tried starting by console command:

Output: Dec 17 17:42:56.357 [notice] Read configuration file "/etc/tor/torrc". Dec 17 17:42:56.360 [warn] Failed to parse/validate config: Unknown option 'service'. Failing. Dec 17 17:42:56.360 [err] Reading config failed--see warnings above.

  1. Used sudo apt-cache rdepends tor and apt-get install rdepends tor to check if there are any dependecies missing, still wont start.

  2. Used sudo netstat -atn to check if port 9050 is in use somehow

Output:

tcp   0      0 127.0.0.1:9050          0.0.0.0:*           LISTEN 
  1. Went to folder where Tor is installed and used ./start-tor-browser with result: No such file or directory; so I also tried after ./tor

Output: Dec 17 18:18:10.607 [notice] Read configuration file "/etc/tor/torrc". Dec 17 18:18:10.611 [notice] Opening Socks listener on 127.0.0.1:9050 Dec 17 18:18:10.611 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running? Dec 17 18:18:10.611 [warn] Failed to parse/validate config: Failed to bind one of the listener ports. Dec 17 18:18:10.611 [err] Reading config failed--see warnings above.

Tor browser is not running though.

PS: I am as noob as they get, so I am sure to miss something, thx for help and I hope I did not waste your time. I need tor :D, we all should.

3

sudo tor --service start

This is for Windows users, not Linux.

--service remove|start|stop

Remove, start, or stop a configured Tor Windows service.

Dec 17 18:18:10.611 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?

Yes, infact tor was already running, as your netstat output showed. It is installed as a system service and would have started already.

tor is not Tor Browser, it is just one component that provides the connection to the Tor network but it doesn't include the browser. Instead you should install Tor Browser by following the steps on the Tor Project website. It is a standalone application and doesn't require you to install tor onto the system itself, as it uses it's own copy but they won't interfere with each other either.

0

Something similar solved it for me. I'm trying to run TOR on ParrotOS (Linux Distro) and sudo service tor start did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.