2

Had no problems using Tor Browser for 4 years or so then all of a sudden 'could not connect to Tor control port'. El Capitan 10.11.6 - Tor 6.05.

I've tried deleting and re-installing Tor, turning off Firewall, running virus checks, disk maintenance, Mac Clean etc still same error.

The one noticeable things is a slight delay as Tor starts.

I can't paste the Tor log because it doesn't generate one - reads '(0) logs ready to be copied to clipboard'. If I click 'settings' I just get 'Waiting for Tor to start' ...then 'Could not connect to Tor control port' again.

I have not recently installed any new software of system updates so no real change in the environment - any ideas would be greatly appreciated

  • Do you have it so it opens a program when you click on a magnet link at all? – user14450 Sep 23 '16 at 9:14
  • No, just a double click on the Tor icon from the apps menu, i've checked the mac's port usage and nothing is using 9150. As mentioned in the first comment, there's a real delay before Tor attempts to open - as if its possibly clashing with something else but not error message occur – SlySi Sep 23 '16 at 11:40
1

Answered there: Tor Launcher: Could not connect to Tor control port

OS X, Yosemite 10.10.5, same problem.

I've deleted Tor application, deleted ~/Library/Application Support folder, installed new stable version and now it works.

  • Bingo!! ...well done sir - problem solved, many thanks – SlySi Sep 26 '16 at 9:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.