Hot answers tagged

14

How do I control the things that Vidalia did?(bridges, start and stop tor) Starting the TorBrowser starts (launches) Tor and closing the TorBrowser closes (exits) Tor. All traffic from the TorBrowser is supposed to go through Tor. Upon first launch of the extracted bundle you have two choices, either you connect to the Tor network directly or you change ...


12

From the Tor Blog's release post: In terms of user-facing changes from TBB 2.x, the 3.x series primarily features the replacement of Vidalia with a Firefox-based Tor controller called Tor Launcher. This has resulted in a vast decrease in startup times, and a vast increase in usability. Vidalia is still available for download as Bridge/Relay/Exit bundles ...


11

Yes. The Tor program caches its directory information -- and it does it the same way inside TBB as it does in, say, the Tor debian package. You can see the files in Data/Tor/ in your tor-browser directory. These files are documented in the Tor man page, under the "FILES" section towards the end. The most interesting two for Tor 0.2.3.x and 0.2.4.x are: ...


8

Normally the Tor service should be started/stopped with either sudo systemctl start/stop tor.service or sudo service tor start/stop. Personally I've always used the service command because it is simpler. I'm guessing things get a little more complicated when you run multiple Tor instances, but I have no experience with that. Running Tor in a terminal runs ...


2

If you run it with sudo, of course it will be run as root. It also makes sense that it uses your HOME directory. Doing a sudo echo $HOME explains why. So this doesn't appear to be wrong, but expected behavior. What you probably want to do is have a torrc and set things like logging using the Log option and User <username>, so privileges are dropped to ...


2

TBB version 3.5 or newer no longer employs Vidalia Control Panel. For more information and how to manually start Vidalia Control Panel if you want to, read Roger Dingledine comment above.


2

It seems you have installed the Tor package, either from Tor directly or as a Debian package. By default the software is set up to start by system start and it always runs in the background. So this is expected behaviour. You can disable this with systemd or with startup scripts.


2

The issue is that the package is aimed at ubuntu, the systemd service file expects apparmor to be there it tries to enforce the profile but the profile isnt loaded or cant be loaded, to remedy this perform the following steps: sudo apt-get install apparmor apparmor-utils This provides the required userspace tooling to load apparmor profiles. Edit /etc/...


2

In Terminal, run "sudo lsof -n -P | grep LISTEN | grep tor". If you see a process named "tor.real" listening on ports 9150 and/or 9151, kill it. Then launch TorBrowser again.


2

The log message you mentioned is just a default log message that gets printed out on every start (doesn't depend on certain config. See: https://gitweb.torproject.org/tor.git/tree/src/core/mainloop/main.c#n3488). Unfortunately you can't disable just this message: To remove it you'll have to disable all logging in your torrc file.


1

Welcome to StackExchange! Based on the question from my understanding the application is slow because the gpg keyring is not connecting to a tor relay if I understand correctly. There are multiple factors that can cause the keyring to not be responsive though most of them may be out of your control. To start off with the more basic problems, are you sure ...


1

Normally users would expect network services that are installed to start automatically, this is true for other network services under debian or ubuntu like httpd or sshd. If you're running a relay or an onion service or another service that depending on using tor as a client then you'd definitely want the tor system service to start automatically.


1

Your COMODO anti-virus is performing DLL injection to spy on your usage of Tor Browser. cmdshim32.dll, where the fault is happening, is part of COMODO. This needs to be fixed from their side. N.B.: Stop using anti-virus if you have anonymity or privacy requirements.


1

It's installed as a system service, the same way as is defined here. It's started automatically at boot by systemd, the system service manager. Tails also has extensive configuration and tweaks for it to use Tor properly, simply installing Tor won't provide the same features but it will start automatically when the operating system starts.


1

Related to this bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=808296 Solved using mkdir /etc/systemd/system/tor@default.service.d/ (echo "[Service]"; echo "AppArmorProfile=") > /etc/systemd/system/tor@default.service.d/override.conf systemctl daemon-reload


1

You need to run the Start Tor Browser.exe executable in the main Tor Browser directory, rather than the firefox.exe you're trying to run. There's a very detailed guide on EFF's Surveillance Self-Defense page on how to run the Tor Browser for the first time on Windows.


1

This is very frustrating, I know. After two hours of deleting and downloading, here is the solution: right-click the .exe file Open "Properties" At the bottom, you will see a checkbox that says "this seems to come from another computer.." then check to allow the file to run. Tor starts. cheers


1

I get that problem behavior only occasionally, at which time I kill the process with task manager and restart TBB. (I also have never heard of Trusteer Rapport - unless that's the software that banks sometimes offer... and I nevertheless haven't installed it.)


Only top voted, non community-wiki answers of a minimum length are eligible