4

You probably logged into your Facebook account over Tor. Facebook sees you exiting the Tor network in Portugal, or what it thinks is Portugal and so it flagged up your own login attempt as suspicious. In future you might consider using Facebook's own Onion Service at https://facebookcorewwwi.onion/.


3

The way to check to see if a website is or is not a phishing attempt is the exact same way regardless of the browser. Click on the information link: Click on the arrow for the certificate on the right: Check the certificate: Facebook has one of the few onion services that uses trusted certificates. They are still expensive and hard to get. If the onion ...


2

The question is basically saying that Facebook started with this onion address, then set out to generate the corresponding private key. This premise is incorrect, as pointed out by Steve’s answer: in fact, this task would be infeasible using current hardware. Where could this incorrect premise have come from? According to Facebook’s announcement [1], their ...


2

Facebook's onion domain has only 8 custom characters, not 15. Since they generated multiple names with those 8 characters, they chose the one that looked best. It is still out of reach of modern hardware to brute-force all 16 characters. Onion names with 16 characters are for v2 onion services, which are deprecated and will be removed from the network later ...


1

What would be the issue? Logically, there are three possible answers: Facebook incorrectly recorded your logins. This seems unlikely; I am not aware of any reports of this. Facebook detected one of your logins as coming from Portugal, despite you not being in Portugal. This was addressed by cacahuatl’s answer: the most likely answer is that you logged in ...


1

It seems to be a NoScript bug. When I disable 'Sanitize cross-site suspicious requests' in NoScript Options\Advanced\XSS then Facebook comments come back. So, it is the first solution to disable 'Sanitize...', but we are vulnerable to XSS attack if permanently disabled. Second solution: tweak the NoScript Options|Advanced|XSS|Anti-XSS Protection Exceptions ...


Only top voted, non community-wiki answers of a minimum length are eligible