6

I recently extracted tor-browser-linux64-6.0a4_en-US.tar.xz on a mounted drive. And tried to start the browser.

The Browser didn't open due to not recognizing the .desktop file which starts the Browser. Later, I was advised to copy and paste it in home directory.

And after pasting it in home directory, it no more shows permission problem or recognizing problem regarding the .desktop file by bash but now, it is showing permission problem in execdesktop file in Browser directory of Tor Browser's root directory.

user@user's-desktop:~$ cd tor-browser_en-US
user@user's-desktop:~/tor-browser_en-US$ ./start-tor-browser.desktop
/usr/bin/env: ./Browser/execdesktop: Permission denied
2

The desktop file doesn't work in any case. However Tor comes with a shell script. You can execute it and Tor Browser will start. It is located in the Browser/ subdirectory:

tor-browser_en-US/Browser/start-tor-browser
  • when try to use start-tor-browser in Browser directory, it shows -- user@user's-desktop:~$ tor-browser_en-US/Browser/start-tor-browser bash: tor-browser_en-US/Browser/start-tor-browser: Permission denied – Battle Hawk Mar 27 '16 at 15:53
1

on Ubuntu 18.10 it works now ... just get into dir once download is expanded

cd ~/src/tor-browser-linux64-8.0.3_en-US/tor-browser_en-US
./start-tor-browser.desktop --help  

which suggests you issue

./start-tor-browser.desktop  --register-app

Launching './Browser/start-tor-browser --detach --register-app'... Tor Browser has been registered as a desktop app for this user in ~/.local/share/applications/

now you have registered the app so its searchable + launchable from dash so

Show applications -> tor   

so launching from dash is possible ... from terminal just cat out above mentioned file ./start-tor-browser.desktop and look for line with Exec which looks like

Exec=sh -c '"/home/ota/src/tor-browser-linux64-8.0.3_en-US/tor-browser_en-US/Browser/start-tor-browser" --detach || ([ !  -x "/home/ota/src/tor-browser-linux64-8.0.3_en-US/tor-browser_en-US/Browser/start-tor-browser" ] && "$(dirname "$*")"/Browser/start-tor-browser --detach)' dummy %k

so to launch directly from terminal issue

/home/ota/src/tor-browser-linux64-8.0.3_en-US/tor-browser_en-US/Browser/start-tor-browser

adjust your downloaded dir as mine is /home/ota/src/tor-browser-linux64-8.0.3_en-US/

-3

This message appears because you didn't gave executable permission to those files now you just go the /browser folder & make those files executable by typing ""chmod +x *"(without any quotes).

Now you will be able to run Tor Browser by executing "start-tor-browser.desktop" or "tor.desktop" any of these files. making executable tor files

  • no chmod +x * is not a good solution. – cacahuatl May 16 '17 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.