1

If I use the pluggable transports bundle with the bridge pack, it tells me my Tor browser needs an update. I have the regular bundle, so can I overwrite that browser with the current bundle or should I just wait until the pluggable transport bundle is updated?

3

Tor doesn't officially support overwriting one bundle with a newer version. Overwriting with a different sort of version or overwriting a 2.x version with a 3.x version is even more likely to lead to problems.

Tor tends to update the “vanilla” Torbrowser bundles first then release PT bundles a little later. Since most Torbrowser updates are security and bug fixes, it's always prudent to use the latest version. If you need to use a pluggable transport to connect to the Tor network, the latest version available for you might lag behind the “vanilla” versions by a few days, and that's unfortunate.

The version check in Torbrowser doesn't currently differentiate between “vanilla” and PT versions, so you may see an update prompt even when there isn't a PT bundle available yet, which is unfortunate. Part of Tor's roadmap for Torbrowser 3.x is to combine the PT and “vanilla” bundles so that there's just one Torbrowser, and it includes all the puggable transports you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.