1

I just updated my Tor with tor-0.2.7.6.tar.gz, but when I run tor, it uses 100% of one of my CPU's cores, even if I run something simple like tor --version. What is going on?

  • What kind of GNU/Linux (distribution) are you running? Did you compile it for yourself? If yes, please tell some details of how you compiled it. – Jens Kubieziel Dec 14 '15 at 7:46
  • @JensKubieziel I use Slackware and used the Tor SlackBuild to build it. – Geremia Dec 14 '15 at 16:25
  • Try to remove --enable-openbsd-malloc option – user10443 Jan 9 '16 at 17:00
  • please post your build options in the question + uname -a – Alexey Vesnin Jan 9 '16 at 17:22
  • trac.torproject.org/projects/tor/ticket/18028#comment:1 > When it's using all the cpu, could somebody try using oprofile or prof or gdb or anything to figure out where it's going? > What's the last version that didn't have this problem for you? – user10460 Jan 11 '16 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.