3
StrictNodes1
ExitNodes {us}

Is no longer working for me after the new update. It seems like it works sometimes and doesn't sometimes. Each time the circuit gets rebuilt I end up in a non-US exit node. No one has been able to figure this out.

I checked the post here: https://stackoverflow.com/questions/13422099/tor-strictexitnodes-is-not-working

I tried to add -f from the command prompt and point to the torrc file. It doesn't work, all it does is try to load that file in the browser.

2
  • 1
    At least in your question you're missing a space between StrictNodes and 1. Is this just a transcription error? Dec 5, 2015 at 19:46
  • Paste your full torrc if you can so I can help troubleshoot and update my answer below. Thanks
    – james-see
    Dec 5, 2015 at 22:52

3 Answers 3

2

You need to make sure it is StrictNodes 1 (<-- With a space before the '1')

This is the relevant section in the Tor documentation: https://www.torproject.org/docs/tor-manual.html.en#StrictNodes

1

As the manual states, StrictNodes does not apply to ExitNodes, only to ExcludeNodes.

From tor(1):

StrictNodes 0|1

If StrictNodes is set to 1, Tor will treat solely the ExcludeNodes option as a requirement to follow for all the circuits you generate, even if doing so will break functionality for you (StrictNodes does not apply to ExcludeExitNodes, ExitNodes, MiddleNodes, or MapAddress). If StrictNodes is set to 0, Tor will still try to avoid nodes in the ExcludeNodes list, but it will err on the side of avoiding unexpected errors. Specifically, StrictNodes 0 tells Tor that it is okay to use an excluded node when it is necessary to perform relay reachability self-tests, connect to a hidden service, provide a hidden service to a client, fulfill a .exit request, upload directory information, or download directory information. (Default: 0)

-1

You must be sure that the following options are set :

GeoIPExcludeUnknown 1
StrictNodes 1
ExitNodes {us}
AllowSingleHopCircuits 0
EnforceDistinctSubnets 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy