1

I'm having problems with correctly starting tor.exe process and connecting with telnet/tcp to Tor in order to send commands.

  • When the tor.exe process is started by Tor Browser (Version 5.0.4) I can easily connect to port 9151 and send commands.

  • If I kill Tor Browser process only, I am unable to connect to ControlPort 9151

  • If I start tor.exe manually, I am unable to connect to ControlPort 9151

My question is, what exactly is Tor Browser doing that I'm missing? And how come that killing Tor Browser process somehow messes up tor.exe and I'm unable to connect after that?

The torrc configuration is correct and all the paths are correct in configuration. Here is the configuration

# This file was generated by Tor; if you edit it, comments will not be preserved
# The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

DataDirectory C:\Users\unknown\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor
GeoIPFile C:\Users\unknown\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor\geoip
GeoIPv6File C:\Users\unknown\Desktop\Tor Browser\Browser\TorBrowser\Data\Tor\geoip6

ExitNodes {US}
StrictNodes 1
SocksPort 9150 IPv6Traffic PreferIPv6
ControlPort 9151
CookieAuthentication 1

I know that Tor expert bundle build for windows has some bugs in it (like not outputting to the console), and I've tried both binaries, from expert bundle and from Tor Browser - none of them worked out for me.

  • You can get around the lack of logs being output to the console by piping to more. For example, tor.exe | more. See if the logs output by this show anything interesting. – Richard Horrocks Nov 30 '15 at 20:45
  • 1
    Thank you Richard! That helped me a lot. The problem was that tor was searching for torrc configuration in AppData/Roaming/Tor folder and used the default configuration with no ControlPort. Problem solved :) – tomcraft Nov 30 '15 at 21:18
2

As Richard answered, running tor.exe | more gives you console output of tor and I was able to see that tor is searching for torrc configuration in AppData/Roaming/tor instead of using configuration file torrc in his own folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.