2

I have tried nginx and apache2. I have configured everything according to all the guides and my hidden service still won't come up. I've done port forwarding to the port I want apache or nginx to redirect to and still nothing. I have a few bitcoin and would be willing to donate if someone can help me get this working. I'm on Ubuntu 14.0.4.

My torrc reads:

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 6666 127.0.0.1:7777

and the Apache2 config has the following components. sites-enable/default.conf

<VirtualHost *:6666>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

apache2/ports.conf

NameVirtualHost 127.0.0.1:6666
Listen 127.0.0.1:6666

<IfModule ssl_module>
    NameVirtualHost 127.0.0.1:443
    Listen 127.0.0.1:443
</IfModule>

<IfModule mod_gnutls.c>
    NameVirtualHost 127.0.0.1:443
    Listen 127.0.0.1:443
</IfModule>

apache2.conf

ServerRoot "/etc/apache2"
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

AccessFileName .htaccess
<FilesMatch "^\.ht">
    Require all denied
</FilesMatch>

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
IncludeOptional conf-enabled/*.conf
IncludeOptional sites-enabled/*.conf
  • Please edit your question to include a copy of your torrc file, together with a copy of either your Nginx config file, or Apache2 config file - whichever one you're using. – Richard Horrocks Sep 29 '15 at 20:41
  • Will do. Give me about an hour or so. Still at work. The files are on my home pc. – Omnicide Sep 29 '15 at 20:56
  • Sorry it took so long. But Ive added my configs to post. – Omnicide Sep 30 '15 at 12:20
  • Can you access 127.0.0.1:6666? What happens when you try to access your hidden service with the onion URL: onionurl.onion:7777? Please substitute the latter with the correct URL. – Jens Kubieziel Sep 30 '15 at 14:36
  • Yes 127.0.0.1:6666 works. Havent tried adding 7777 after the onion url. Didnt even think about that. Ill try it tonight after work. – Omnicide Sep 30 '15 at 14:43
2

NameVirtualHost 127.0.0.1:6666
Listen 127.0.0.1:6666

Your server listens to port 6666 ..

HiddenServicePort 6666 127.0.0.1:7777

.. but your Tor tries to connect to 7777

You should change your HiddenServicePort directive to
HiddenServicePort 6666 127.0.0.1:6666
or even
HiddenServicePort 80 127.0.0.1:6666 (in this case, you don't have to put a port number in the .onion url.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.