My laptop runs TAILS as its only OS. I never use any other distro, and don't intend to. I am trying to do this and I have downloaded all six necessary packages of software (I'm not using Google Apps).

My problem is that when I run the command:

apt-get install android-tools-adb android-tools-fastboot

I get this:

Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package android-tools-adb E: Unable to locate package android-tools-fastboot

I have booted my tablet (Nexus 7, 2013, WiFi only, running Lollipop) into fastboot and plugged it in. I have tried using the root terminal, and using sudo apt-get install android-tools-adb android-tools-fastboot in the normal terminal as amnesia user.

I am fairly new to Linux, but am interested and learn pretty quickly.

2 Answers 2


On the page you've linked to, in the Installation and Setup: ROM and Core App Installation section, the instructions state:

Then, attach it to your desktop/laptop machine with a USB cable and run the following commands from a Linux/UNIX shell...

I think there's an assumption that the desktop/laptop you're using to do this won't be running Tails. The problem will be that Tails doesn't know where the Android packages are located, with the solution being to update its list of known sources.

To do this, follow the instructions on the Tails Install Additional Software page, the important one being:

apt-get update

This should be run as root, so you'll need to make sure you have an administrator password set up (which is also described in those instructions). Note that a similar thing can be done in the Synaptic Package Manager - you don't have to do it from the command line.

Once this update is completed you should be able to install the Android packages.


I've been able to setup ADB in Tails:

On the computer:

sudo apt update
sudo apt install adb
sudo iptables -I OUTPUT -d localhost -o lo -p tcp --dport 5037 -m owner --uid-owner amnesia -j ACCEPT

On the phone:

  • Got to Settings → System → About phone
  • Hit 7 times on Build number
  • In the previous menu, an entry Developer options should appear now
  • Open it, scroll down and activate Android debugging
  • Connect the phone to the computer
  • Switch the USB mode to File transfer or Data
  • Accept the access authorization on the phone

See this post for reference and troubleshooting

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .