I use Arm with Tor from the Tor repositories on a standard Debian Wheezy (7, oldstable) server.

When I first launch arm I am not sure whether tor is already running. No nickname is indicated in the Arm panel header. I configure my relay with the Arm Setup Wizard. Once the wizard completes, Arm outputs the message:

[ARM_NOTICE] Tor needs root permissions to start with this
 configuration (it will drop itself to the current user afterward). To
 - open another terminal
 - run "sudo /home/myusername/arm/startTor"
 - press 'r' here to tell arm to reconnect

(by the way, typing r should be done in the Tor Configuration File panel and only once Tor has been stopped. In the main Arm page typing r just resizes the graphs.)

Once I have done as instructed, my relay nickname & exit policy are displayed in the Arm header, and it progressively picks up activity. Nevertheless, Arm shows this warning (which does not seem to have an effect):

[ARM_WARN] the torrc differs from what tor's using.
You can issue a sighup to reload the torrc values by pressing x.

My problem is this: every time I reboot, I have to start all over again! It seems that the torrc created/edited by Arm is not persistent. This is not just inconvenient: I am afraid that after a power outage, my relay will just boot back into a default exit relay configuration.

What am I doing wrong?

1 Answer 1


You are not doing anything wrong. The message you see is in fact a false alarm. According to the arm maintainer:

That message simply means that tor is currently running with the 'RunAsDaemon' option enabled, but this setting isn't in your torrc. This message is meant to help people who edit their torrc, forget to restart tor, and are then confused why the settings didn't take effect.

A simple solution is to edit your /etc/tor/torrc file and then run systemctl restart tor (for systemd). You can also copy the contents of ~/.arm/torrc into /etc/tor/torrc and then start tor by /arm/startTor.

  • The message itself is not my problem… what I am concerned about is that every time I reboot, I have to re-configure Tor through Arm so that my relay runs with my configuration.
    – doobadooba
    Commented Sep 20, 2015 at 7:58
  • Simplest solution is to edit the /etc/tor/torrc file, restart tor and then launch arm and ignore the message.
    – Ron
    Commented Sep 20, 2015 at 9:05
  • I replaced /etc/tor/torrc with ~/.arm/torrc (the file that resulted from Arm Setup Wizard), and now when I launch arm, I am immediately prompted by the Wizard again… my settings have somehow been lost. What am I doing wrong?
    – doobadooba
    Commented Sep 20, 2015 at 12:52
  • Ah! I had to start Tor again via the /arm/startTor script -- it was my understanding that Tor would start by itself at reboot (as a "deamon"), but it does not. So, replacing the contents of /etc/tor/torrc with those of ~/.arm/torrc solves my problem. @Ron, can you edit your answer, or write a new one with this?
    – doobadooba
    Commented Sep 20, 2015 at 13:01
  • @doobadooba yes, as "...people who edit their torrc, forget to restart tor, and are then confused why the settings didn't take effect." ;) Edited by question. You may accept it as the answer if it helped you ;)
    – Ron
    Commented Sep 20, 2015 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .