9

When running Tor via the Tor Browser Bundle, Vidalia works fine, Tor runs and connected, Firefox runs and connects to https://check.torproject.org which tells me that I have Tor enabled with an IP address from Germany or something, but there's just one thing.

The keyboard doesn't work!

I can't use the keyboard at all, not in inputs, not in the browser bar, not with keyboard shortcuts, nothing.

I use Ubuntu 13.10 x64, I chown all the files in the directory.

  • 3
    This is a known bug: trac.torproject.org/projects/tor/ticket/9353 – bastik Nov 9 '13 at 15:40
  • @bastik: I seriously doubt that everyone who has Tor on a 64 bit system gets that though, can't I do anything to solve it? (I tried uninstalling ibus btw and it didn't work) – Madara's Ghost Nov 9 '13 at 20:21
  • Others wrote that stopping the process from running helped, I don't know. It seems that this is more a support question. torproject.org/about/contact.html.en#support There are a bunch of people and they might know what works best. This Q&A might not be suited for solving this problem. Well maybe if there's an easy answer. Overall I hope this will be fixed 'soon' and render your question obsolete. – bastik Nov 10 '13 at 8:41
  • @ Madara Uchihia the 'AT' part gets stripped out over and over again – bastik Nov 10 '13 at 8:42
  • I don't have an answer, but I have the same problem (I'm running 13.10, 64 bit). Also, clicking on start-tor-browser doesn't work even though nautilus has the executable box checked. It brings up gedit instead. The only way to make it run is to open a terminal and execute the command that way. – user529 Nov 11 '13 at 19:24
7

It is a known bug on ibus-x11 on Ubuntu 13.10 amd64

According to the open Trac ticket you should killall ibus-x11

  • 1
    The last workaround in the ticket with export GTK_IM_MODULE="xim" does not work for you? killal ibus-x11 is rather brutal. – pabouk Nov 18 '13 at 19:46
  • yep, this solution worked for me: askubuntu.com/a/377321/62483 – Lucio Dec 13 '13 at 1:28
-2

open ubuntu software center, search ibus, then uninstall.

  • 1
    Can you clarify how this would fix the problem? – Andrew Lott Jan 11 '14 at 15:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.