2

So I'm trying use a java plugin for a game at work. Downloaded portable Firefox/Jportable have it configured with new Java. Wanted to open tor portable and use a separate Firefox portable to use game since Tor portable doesn't Java. Connects fine on computer, but i cant update java on computer hence switching to portable. I get the error -

Tor failed to establish a Tor network connection.

Connecting to a relay directory failed (missing pluggable transport - 109.105.109.163:38980)

heres the log:

8/27/2015 16:46:01 PM.200 [WARN] Failed to create child process TorBrowser\Tor\PluggableTransports\obfs4proxy: The system cannot find the file specified.   
8/27/2015 16:46:01 PM.200 [WARN] Managed proxy at 'TorBrowser\Tor\PluggableTransports\obfs4proxy' failed at launch. 
8/27/2015 16:46:01 PM.600 [NOTICE] Bootstrapped 5%: Connecting to directory server 
8/27/2015 16:46:01 PM.600 [WARN] We were supposed to connect to bridge '109.105.109.163:38980' using pluggable transport 'obfs3', but we can't find a pluggable transport proxy supporting 'obfs3'. This can happen if you haven't provided a ClientTransportPlugin line, or if your pluggable transport proxy stopped running. 

What do?

  • Could you add the configuration you used? Please try to describe what you tried and what didn't work. Currently it is hard to understand what your question is about. – Jens Kubieziel Aug 28 '15 at 15:53
  • Okay so originally I set Tor up on my work computer to play a game that runs Java plugin. This way i was able to bypass the web blocker. It connected perfectly using the same configuration, connecting through bridge 'obfs3' and no proxy. However, Java is not updated to most recent version and i need admin access to update it. Therefore I decided to go portable, because I can actually update and run Java from there. I downloaded firefox portable and Jportable, and then Tor portable last. When i go to run tor portable from my flash drive i get the above error, using the exact same configuration – maximillion Aug 28 '15 at 17:04
  • So my question is what exactly am i missing here? I have tried every preloaded bridge and i get the same error. It works fine on the computer, but when i run it from the Flash drive i get issues. What can i do to get this to work? I also tried opening tor on the computer, keeping that window open, then opening firefox portable to run it through tor in another firefox window. However when i go to any game site on the portable version i get blocked as though i didnt have Tor running. so i assume that doesnt work and i need to use the portable tor version – maximillion Aug 28 '15 at 17:08
1

I used to have a similar problem as you. Now it is fixed for me, using the method described here:

https://trac.torproject.org/projects/tor/ticket/17377

obfs4proxy crash no apparent reason
Problem solved by change the relative path in the torrc-defaults to absolute path where the installation path insdead

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.