8

I created a Tor hidden service (a server binded to localhost port and torrc config'd to use the 127.0.0.1 xxxx) for clients to connect to. It was working great for a month or so, and now no one can connect to it. I see it is still setup properly in my torrc, and restarting tor seems to work and it says it's reading from /etc/torrc.

Here's my log from the server:

Aug 13 10:55:11.000 [notice] Bootstrapped 5%: Connecting to directory server. 
Aug 13 10:55:11.000 [notice] We now have enough directory information to build circuits. 
Aug 13 10:55:11.000 [notice] Bootstrapped 80%: Connecting to the Tor network. 
Aug 13 10:55:11.000 [notice] Bootstrapped 85%: Finishing handshake with first hop. 
Aug 13 10:55:12.000 [notice] Bootstrapped 90%: Establishing a Tor circuit. 
Aug 13 10:55:13.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working. 
Aug 13 10:55:13.000 [notice] Bootstrapped 100%: Done. 
Aug 13 10:56:38.000 [notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later). 
Aug 13 10:56:53.000 [notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later). 
Aug 13 10:57:21.000 [notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later).

The client machine tor log says the same thing:

Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later).

On the client end it says the service is unavailable, but on the server end, tor is running, and the server process is running.

How can I troubleshoot this?

  • Can you paste your torrc for the hidden service configuration? What ports is it running on? Can you visit the service from the local machine? 9/10 times this isn't a Tor problem but a host configuration – Lizbeth Aug 13 '15 at 18:23
  • 1
    the only thing ive modified in my torrc was this: HiddenServiceDir /var/lib/tor/myhiddenservice/ HiddenServicePort 12345 127.0.0.1:12345 and it worked before, for a few weeks. the service is running as a user with sudo priveledges. i also have apache2 running as root on the same machine hosting a website(which was done by the admin a few weeks after i set up my tor hidden service, and seems to be around when the problem started) the service on 12345 is running fine, and it is definitely working properly. – user8125 Aug 13 '15 at 19:26
  • k got an account. so i have a correction. the root user is just running a nodejs file using port 80, hosting itself.. apache2 isnt running.. – sunerok Aug 13 '15 at 19:57
  • For others landing here - I fixed by changing the system timezone to UTC. – coding_idiot Jun 28 '18 at 17:22
5

Ok, I figured this out. For some reason the custom onion address I made with Shallot was no longer working. I made a new hidden service and got rid of the existing one, restarted Tor, and voila! I'm not sure why this happened, but this solved both hidden services that had stopped working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.