1

I'm working with a GL-iNET router, and before it stopped working, it was running their tor firmware from 2/2/2015 (the file doesn't have a version number).

At some point it broke and now when it turns on, the LED flashes red. I couldn't find a manual for the device, and I'm not that familiar with Open-WRT/DD-WRT (the tor firmware is based on one of these). Would this be something to consult their documentation about?

What does a flashing red LED mean? After it boots up, it flashes ~4/sec green for ~3 -4 seconds, then it flashes red ~4/sec. Periodically, the LED will stay red for a little while longer and then it will resume its normally 4/sec flash rate.

The wifi is broadcasting (I can see the SSIDs), and I can access the web UI via the LAN port (and presumably the non-tor wifi). I've reset the device before, but I'd like to know what's going on.

closed as off-topic by Stig Atle Steffensen Jan 8 '16 at 16:33

  • This question does not appear to be about Tor, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Seems like a hardware/firmware issue, not a Tor issue. Might need to contact the manufacturer for support. Solid lights on hardware often means that it's bricked in a static state that would require you to reset it back to factory defaults and/or reflash the firmware... but I have no idea – Lizbeth Aug 6 '15 at 14:35
  • This question is off-topic and not about tor. – Stig Atle Steffensen Jan 8 '16 at 16:33
0

After some digging, it turns out that the LEDs are configurable in OpenWRT, and on this device they were configured to blink red by default. I didn't quite get all the settings and what they meant, but I found the docs by searching for the current values.

This page goes over the capabilities of the LED and what they mean (scroll down to WiFi activity).

The default is to blink the LED red on phy0tpt, so I fiddled with the settings to get the router to do what I wanted. It seems that the LED settings will take effect without a reboot, but I had to do a power cycle to get them to fully take. Before the power cycle, i was getting multi-colored flashes. Afterwards, solid green like I wanted.

Now that I have the docs and know what it means, I may play around with it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.