4

I downloaded TBB version 4.5.3 for GNU/Linux and extracted it on OpenBSD version 5.7 (current version which is basically a daily snapshot.)

I unzipped TBB on the said OS and after I cd to the directory where the contents of TBB had been extracted, I typed the following command:

./tbb    -v

and many error messages appeared.

Why does the "Download Tor" page claim that TBB is vaild for *BSD operating systems when it does not work on OpenBSD 5.7?

1

I do not have a specific answer, there seems to be several issues, there is however a project website that's trying to change this.

https://torbsd.github.io/

The Tor BSD Diversity Project (TDP) is an initiative seeking to extend the use of the BSD Unix operating systems in the Tor public anonymity network.

They have a repo for a tbb ports package:

https://github.com/torbsd/openbsd-ports

They do also state in their faq:

“Doesn’t the Tor web site download page list a Tor Browser Bundle for GNU/Linux, that also supports ‘Unix, BSD’?”

"That is true, but unfortunately inaccurate. The current Tor download does not work on any of the BSDs for a variety of reasons."

  • Thanks very much for TorBSD's faq "That is true, but unfortunately inaccurate. The current Tor download does not work on any of the BSDs for a variety of reasons.". – user281403 Aug 2 '15 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.