My proxy setting does not work in Tor. I have no idea why. The same settings work in Firefox. (the proxy is working. I keep checking and changing it): Current Tor proxy settings

What am I doing wrong?

  • Are you overriding the Tor browser settings or trying use Tor to connect to a SOCKS proxy?
    – Lizbeth
    Commented Jun 30, 2015 at 16:10

3 Answers 3


If you want to use individual network settings you have to disable TorButton. Otherwise your settings won't have any effect.

Click on the burger symbol (right above) and select "Addons". You can also enter about:addons into the address bar. Now you'll find the TorButton addon and you can deactivate it. If you change network settings and apply them, they are used by TBB.

However I wouldn't advise to do it, because TorButton does more than only changed proxy settings. So deactivating it, might have negative effects on your anonymity.


You are not doing anything wrong. That's exactly how it works. In TOR, proxy is meant to bypass security restrictions and filters.

To make it possible, traffic is passed through the proxy server at the starting place not at the end.
I.e., browser -> proxy server -> TOR network -> website

If you disable Torbutton add-on as others suggests, it will open vulnerabilities by allowing some kind of active contents.

tor browser screenshot


Try to use FoxyProxy in Firefox. Tor Browser is a Firefox too. In case of problem persists, disable Torbutton and use just FoxyProxy.

  • 1
    If the OP is using Tor for reasons of anonymity, then recommending they use standard Firefox is a dangerous suggestion, as per Jens' answer. Commented Dec 29, 2015 at 10:27
  • @RichardHorrocks I'll disagree : take a look at persistent cookies like evercoockie - no browser-based solution will save you from that, INCLUDING TorButton. So, I disagree with you again
    – Alexey Vesnin
    Commented Dec 29, 2015 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .