0

I am trying to set up a tor non exit relay, i am running it on debian wheezy inside of a virtual machine run in hyper-v on server2o12 r2 datacenter, my router is a ubiquiti ER-8Pro both ports 9001 and 9030 are forwarded to the virtual machine (The VM has a static ip and its own dedicated nic)and are opened in the firewall, i used the port scanner on whatsmyip.org to verify that both of those ports are open, and they are, however the log is showing an error saying it has not managed to confirm that the ports are open. does anyone have any idea on what the solution to this would be?

  • Are there any software firewalls on the box or iptables rules that might be blocking it. The only time I've ever seen Tor not be able to verify the port was open, was when there was a networking problem. I'd focus efforts on it being a firewall issue. If you've opened the ports on the firewall, the ports will appear open, but if you haven't forwarded it to the correct internal IP, the ports will still be open but the service won't work. Make sure your box is set to a static IP and isn't accidentally falling back to being DHCP. – Lizbeth Jun 18 '15 at 15:01
  • I removed the firewall on the tor box and disabled the one in the router and still no success, the ip is static and the correct ports are forwarded to it, i also tried letting it use dhcp and reserving the assigned address to the box for that box and forwarding the ports there aswell, and still no success – Wered Jun 23 '15 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.