3

I have been trying to test it out, I've changed the ORPort and DirPort and forwarded them on the router but I keep getting the following messages.

pi@raspberrypi ~ $ tail -f /var/log/tor/logled--see warnings above.
tail: cannot open `/var/log/tor/log' for reading: No such file or directory
pi@raspberrypi ~ $ sudo service tor restart
[ ok ] Stopping tor daemon...done (not running - there is no /var/run/tor/tor.pid).
[....] Starting tor daemon...Jun 09 11:17:47.968 [warn] Could not bind to 127.0.0.1:9050: Cannot assign requested address
Jun 09 11:17:47.970 [warn] Could not bind to 127.0.0.1:9051: Cannot assign requested address
Jun 09 11:17:47.979 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Jun 09 11:17:47.981 [err] Reading config failed--see warnings above.
failed.

How do I get it working and is it even advisable?

@Lizbeth I tried to change sockport to 0 and this the error I get

FAIL] Checking if tor configuration is valid ... failed!gi.com.au
Jun 10 16:54:12.724 [notice] Tor v0.2.4.27 (git-412e3f7dc9c6c01a) running on Linux with Libevent 2.0.19-stable and OpenSSL 1.0.1e.
Jun 10 16:54:12.726 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jun 10 16:54:12.727 [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
Jun 10 16:54:12.729 [notice] Read configuration file "/etc/tor/torrc".
Jun 10 16:54:12.778 [warn] Failed to parse/validate config: Unknown option 'SockPort'.  Failing.
Jun 10 16:54:12.788 [err] Reading config failed--see warnings above.
2
  • Is a different process listening on port 9050?
    – user66
    Jun 9, 2015 at 12:02
  • Im sorry but Im a bit of a noob. Do you mean on the client than no. I followed the exact same steps to set up my first one just changed the OR and Directports and forwarded those on the router. This are the instructions i followed on a fresh raspbian image running headless and updated. devconsole.info/?p=879 works perfect for the first on but not the second one.
    – Hani Umer
    Jun 9, 2015 at 15:28

2 Answers 2

1

You can run as many of them as you wish : they're not interfering to each other. To ensure proper speed and connectivity make sure they have been separated by external IP's, that's it.

2
  • "The same LAN" means the same IP address. You can only run 2 relays on the same IP, any others will be ignored. Read the question, provide accurate information. Jun 5, 2016 at 22:34
  • 1
    @supersluether same one LAN can have a multi home router to contact outer world. Please read my answer and take a look at external IP part
    – Alexey Vesnin
    Jun 6, 2016 at 0:28
0

You've changed ORport and DirPort but you haven't changed SOCKSport. By default it listens on port 9050/TCP so you'll need to change this. I recommending setting it to 0 to disable it completely.

3
  • Im sure I tried that yesterday. Im certain I did change it to 9051 or something to make it different. I will try again in a few hours to be sure and post if it still has the same problems.
    – Hani Umer
    Jun 10, 2015 at 16:25
  • Still get an error Ive edited the question
    – Hani Umer
    Jun 10, 2015 at 16:59
  • 3
    "Unknown option 'SockPort'." <-- that is (was?) your typo. It should be SocksPort not SockPort (missing s between k and p)
    – Jobiwan
    Aug 9, 2015 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .