0

I installed the vidalia on ubuntu 14.04 using

apt-get install vidalia

the logs at /var/logs/tor/log tells that everything went OK (See https://gist.github.com/waqaskhan137/86a9e1029d90dda03a68). if i try in terminal vidalia it says

GConf-WARNING **: Client failed to connect to the D-BUS daemon:
An AppArmor policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender="(null)" (inactive) interface="org.freedesktop.DBus" member="Hello" error name="(unset)" requested_reply="0" destination="org.freedesktop.DBus" (bus)

(<unknown>:19383): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

if i use the sudo it says

No protocol specified
vidalia: cannot connect to X server :0

If i try to run it using the gui it just doesn't show anything

Video of the issue

Thanks,

  • Vidalia is not supported anymore. So it is probable that no one can help here. However the error message states a problem with apparmor. You might try to disable AppArmor for a moment and start Vidalia. However in the long-term you should try to use Tor Browser and not Vidalia anymore. – Jens Kubieziel Jul 2 '15 at 12:09
1

A similar question was also asked at AskUbuntu. The recommendation there was to run the following commands. They remove the AppArmor profile for Vidalia and restart Tor:

sudo ln -s /etc/apparmor.d/usr.bin.vidalia /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/usr.bin.vidalia
sudo /etc/init.d/tor start

If you start Vidalia now, it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.