5

I'm having some trouble in setting the country of the tor exit nodes. Following this link, by adding the bellow entries to the ./Data/torrc

ExitNodes {ru}
StrictNodes 1

an exit node from the specified region should be used. However, geo locating the exit nodes shows that none are from Russia. Upon picking a new identity the exit node always remains in the EU or US. Why is that?

  • I don't have an answer for your question, but I wanted to say that I tried those configuration commands with my copy of the Tor Browser Bundle and it seemed to work. Perhaps you put the commands in the wrong configuration file? Try putting nonsense into your config file and then running the command ``tor --verify-config''; if it doesn't complain then that means you're using the wrong config file – user194 May 13 '15 at 10:07
  • @user194 I have tried it in the latest version of tor(4.5) and it worked. It doesn't work in version 3.5. – Sebi May 13 '15 at 14:42
  • if that answers your question, please update it to show this is closed – Lizbeth May 19 '15 at 20:30
  • @ Lizbeth Done. – Sebi May 20 '15 at 11:14
  • @sebi Actually it would be better if you posted it as an answer, and later accepted it. – landroni Jun 7 '15 at 17:56
1

Changing to a more recent version of TOR(>= 4.5) allows for specific exit node selection. The issue may have been caused by high latency; in the previous versions of TOR circuits with a certain delay may have been disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.