1

I'm attempting to set up my raspberry pi as a tor relay. I found some instructions on Instructable: http://www.instructables.com/id/Raspberry-Pi-Tor-relay/?ALLSTEPS

I'm only concerned for steps 1-6, since I can't get the tor browser due to the type of processor in the pi(and I'm almost positive I don't need it for the relay to work).

I can get to the end of step 6 and get: Tor has successfully opened a circuit. Looks like client functionality is working. But when I check Atlas or Globe the relay nickname doesn't show (I let it run 12 hours before checking).

Is there any way to confirm the relay is actually working? (i.e. monitor bandwidth? I know Stem can work, but you need the browser to get the info [I think])

Any help would be great, thank you.

0

I think via https://exonerator.torproject.org/ you should find your answer.

Please let me know if this helps you, I am new here.

2

Do you see a message in the Tor notices log that says the ORPort and/or DirPort are confirmed as working? It should log "Self-testing indicates your ORPort is reachable. Excellent."

Check your port forwarding first. If that appears to be setup correctly then it could be due to a similar situation I was in. I had needed a Dynamic DNS before my ORPort/DirPort could be reachable. See here: Relay getting traffic showing as unreachable?

  • Unfortunately, I have to run to work, so I won't be able to try this now. I have a feeling it's going to boil down to some port forwarding, just hoping there was a quicker solution. I'll try yours tonight! – T.J. Apr 26 '15 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.