Tor had been working fine for a while, but I modified the torrc file and tried to restart and now it will not start again. I removed the edit but now it still will not start. Terminal Output:

[root@EU1 ~]# /etc/init.d/tor status
tor is not running
[root@EU1 ~]# /etc/init.d/tor start
Raising maximum number of filedescriptors (ulimit -n) to 16384.
Starting tor:                                              [  OK  ]
[root@EU1 ~]# /etc/init.d/tor status
tor is not running
[root@EU1 ~]#

Other Terminal Output:

[root@EU1 ~]# tor --service start
Feb 07 08:52:50.002 [notice] Tor v0.2.5.10 (git-42b42605f8d8eac2) running on Linux with Libevent 1.4.13-stable, OpenSSL 1.0.1e-fips and Zlib 1.2.3.
Feb 07 08:52:50.002 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Feb 07 08:52:50.002 [notice] Read configuration file "/etc/tor/torrc".
Feb 07 08:52:50.004 [warn] Failed to parse/validate config: Unknown option 'service'.  Failing.
Feb 07 08:52:50.004 [err] Reading config failed--see warnings above.
[root@EU1 ~]#

Contents of my torrc file:

HiddenServiceDir /home/tor/www/.config/1
HiddenServicePort 80

Any ideas why this could be?

  • Is Tor allowed to write to /home/tor/www/.config/1? – Jens Kubieziel Feb 12 '15 at 15:54
  • how does someone get help with this problem when they don't know what the *&%& you are talking about? By the way in case you are wondering that's probably most of us. – user8008 Aug 1 '15 at 20:11
  • # Permissions on directory /var/lib/tor/hidden_service are too permissive. $chmod 700 /home/tor/www/.config/1 – hktalent Jun 20 '18 at 16:32

You're starting it wrong. You perhaps want service tor start, depending on your OS.

What you're doing here is running Tor, as root, with commandline arguments of --service start. Tor has never heard of the --service option, so it says so and closes.

(That said, my guess is that your underlying problem is that your Tor daemon doesn't have permission to write to /home/tor/. Your Tor logs should say something like this, but Tor might be exiting before it gets around to writing out that log line.)

| improve this answer | |
  • I have started it many times with the command /etc/init.d/tor start and the tor --service start I found in the Tor documentation. The output of tor --service is [warn] Command-line option '--service' with no value. Failing. which leads me to believe it is a command. – CarlosAllende Feb 7 '15 at 6:16
  • Output of service tor start is this: [root@EU1 ~]# service tor start Raising maximum number of filedescriptors (ulimit -n) to 16384. Starting tor: [ OK ] [root@EU1 ~]# service tor status tor is not running [root@EU1 ~]# same error – CarlosAllende Feb 7 '15 at 6:17
  • Last time I ran into this error I think I fixed it by editing the torrc file, but I cant seem to find anything wrong with it now, given its only two lines – CarlosAllende Feb 7 '15 at 6:18
  • 1
    The --service option is for Windows, where it starts, stop or removes a Windows service. – Jens Kubieziel Feb 12 '15 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.