1

Can a 504 error be fixed? Please help me. no matter what deepweb site I search on orweb or orfox it results with the 504 error. Don't know what to do. I have a galaxy s3 mini and don't want to root it.

2
  • Have you only tried one hidden service? If yes, please go to ahmia.fi and try to connect to other hidden services. Also the DuckDuckGo and Facebook hidden service are good examples for reachable hidden services.
    – Jens Kubieziel
    Jan 27 '15 at 8:43
  • My friends i'm Medin. I tried everything u told to do and nothing works. Maybe more ideas? The search page works but the hidden pages doesn't. Thank u for ur time
    – user6601
    Jan 27 '15 at 20:40
1

This error means you're not receiving a response from the server you're trying to connect to in due time. The likely cause is that you are running Orweb on an unrooted Android device. There is a solution however that does not involve rooting the device:

  1. If you are connected to the internet on your phone through WiFi, open your WiFi settings, press and hold on the WiFi connection name you're connected to, and choose "Modify connection config", and check "Show advanced options" and enter "localhost" in the "proxy hostname" field and "8118" in the "proxy port" field. Press "Save" and you should be able to browse through Tor now.
  2. If you are connected through 3G/4G, find the "Mobile Networks" in your main settings (it is under "More settings" in some devices), press "Access Point Names", then press on the access point with radio button checked (if there isn't any you'll have to create a new one). Inside the access point name settings, put "localhost" and "8118" in the respective fields of "Proxy" and "Port".
1
  • I don't think your solution will help. The status code 504 is a Gateway Timeout and orbot usually installs with the appropriate settings. I looks like that the Privoxy couldn't connect to some hidden service.
    – Jens Kubieziel
    Jan 27 '15 at 8:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.