2

I recently starting getting errors starting the Tor Browser on my Debian machine. These errors are fairly new occurring first in the last couple months. I have tried install older versions of the Tor Browser and nothing is working now (though these older versions did work in the past).

When I start I get this error

Tor unexpectedly exited. This might be due to a bug in Tor itself, another program on your system, or faulty hardware. Until you restart Tor, the Tor Browser will not able to reach any websites. If the problem persists, please send a copy of your Tor Log to the support team.

When I attempt to open in the terminal, I get the following output

Launching Tor Browser for Linux in /home/user/tor-browser_en-US/Browser...
Dec 26 10:33:21.166 [notice] Tor v0.2.5.10 (git-13318a95ddfbbf8d) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.1i and Zlib 1.2.7.
Dec 26 10:33:21.166 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Dec 26 10:33:21.166 [notice] Read configuration file "/home/user/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc-defaults".
Dec 26 10:33:21.166 [notice] Read configuration file "/home/user/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc".
Dec 26 10:33:21.170 [notice] Opening Control listener on 127.0.0.1:9151
Dec 26 10:33:21.170 [warn] Could not bind to 127.0.0.1:9151: Cannot assign requested address
Dec 26 10:33:21.170 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Dec 26 10:33:21.170 [err] Reading config failed--see warnings above.

The error seems to occur at the cannot bind to requested address line, but I cannot make heads or tails of it.

Any help or direction resolving this issue would be greatly appreciated.

  • It complains that it is unable to bind to a port. In this case 9151. It is probably in use by another process. You can use netstat to check. Alternatively, you may have an error in your config, where you use the same port for different listeners. Like control and socks. – Jobiwan Dec 27 '14 at 22:30
  • Can you check the output of netstat -tulpn | grep '127.0.0.1:9051'? This will tell you what, if anything, is already listening on that port. – Sam Whited Dec 27 '14 at 23:26
  • When I run the above it tells me to see all process I must run as root, when I run as root there is no output – user5379 Dec 28 '14 at 3:42
  • I just noticed that I used port 9051 and you're trying to bind to 9151. Can you confirm that you used the correct port (or rerun with the correct port)? Sorry. – Sam Whited Dec 28 '14 at 14:46
  • I reran with the correct port and again no output – user5379 Dec 28 '14 at 15:11
2

As per this suggestion

http://www.linuxquestions.org/questions/debian-26/why-apt-get-comes-with-error-on-this-802849/

I ran

ifconfig lo up

and everything worked. I have zero clue what this does, and if someone writes this up better I will accept their answer, but until then I will leave this here to hopefully help people with the same problem

0

With torbrowser problems, the first thing you need to do is start up the browser in verbose mode, as OP has done.

./start-tor-browser.desktop --verbose

Pay attention to the warning messages before the error.

In my case, the issue was that the directory was owned by a different user, this was sufficient to stop tor from starting up.

The error that OP saw, is an error that I see after first installing TOR, killall tor, and then restarting the tor services fixed this for me. Tor was already hogging a socket, yet it wasn't running properly, restarting tor services fixed that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.