1

I'm a first time user of Tor. My search result using the Tor browser does not include the http:// in the URL bar. And the results (an online newspaper) looks "funny" and h as letters and writing all over it that's normally not there. Why can't I get the http: in the URL bar ?

Am I using the browser wrong?

  • 2
    Could you show a screenshot of the "funny" results? – l0b0 Nov 20 '14 at 17:23
3

The Tor browser is based on Firefox, which since some time doesn't display the "http://" part of the URL you navigated to. This simply mirrors the fact that you don't need to type "http://" at the start of the URL in any modern browser, so it's not really helpful to display it.

It will display "https://" if you go to SSL-enabled sites.

3

As mentioned in previous answer, Tor is based on Firefox, which by default trims URLs, and won't show the schema part on the URL bar if the site you're browsing to uses plain HTTP protocol.

There's a (hidden) setting to disable that:

  1. Go to about:config (type that into the URL bar).
  2. Firefox (the Tor Browser) will warn you of being about to modify advanced settings, in a way that's enough to scare some novice users. Just confirm that you'll be careful, if you really want to take the risk; just don't do it if you don't trust me ;-)
  3. Then search for the browser.urlbar.trimURLs setting, and double click it to switch its value from true to false (it will become bold indicating that the default value was changed; you can undo this change any time).
  4. With this sole change the URL bar (as well as the URL tooltip that appears at the bottom of the window when you hover on links with the mouse) will always display the full URL.

I don't think this will make with your search results look less "funny", however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.