2

I just set up a Tor Bridge on a Amazon AWS Server (very good explanation how to do that on https://cloud.torproject.org/).

Now its up and running and I try to access it. I copied the private key (tor-cloud-servers.pem) into my home directory and then tried:

ssh -i tor-cloud-server.pem [email protected]

But it says "Identity file tor-cloud-server.pem not accessible. No such file or directory".

How can I solve this?

1
  • not sure if this got solved but you must connect as ubuntu@ec2-xxx-xxx-xxx-xxx... not as root
    – bnm
    Apr 6, 2015 at 2:59

1 Answer 1

4

Looks like ssh can't find your key file. Is the file name tor-cloud-server.pem or tor-cloud-servers.pem?

And are you running this command from your home directory? If not, try an absolute path:

ssh -i ~/tor-cloud-server.pem [email protected]

1
  • to add something to the previous answer, there is also another possibility for a different user that this .pem file downloaded has a difference extension other than the required .pem. such behaviour has beeen noted in some browsers and Amason advices that file only requires renaming.
    – Denis
    Nov 10, 2014 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .