1

I managed to get my private_key and hostname following the instructions here, which I copied over the one generated by starting the tor browser, in the hidden_services folder. (EDIT: Not sure it's important, but I ran scallion in windows.)

When I start ./start-tor-browser (TBB 4.0.1 in Ubuntu), I get a message:

Nov 02 18:16:01.000 [notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later).

Every now and again I see this in the tor log:

Nov 02 17:32:25.000 [warn] Could not open "/var/lib/tor/hidden_service//private_ key": Permission denied
Nov 02 17:32:25.000 [warn] Error reading private key from "/var/lib/tor/hidden_s ervice//private_key"
Nov 02 17:32:25.000 [err] Error loading private key.
Nov 02 17:32:25.000 [warn] Error loading rendezvous service keys

I am 100% certain that it's relevant, even though it's staggered by about a half an hour (ie, it's now actually 6:23, so really... almost a whole hour).

For sh*ts and giggles, I chmod'ed to 777. It had no effect (still 'unable to connect, firefox can't establish a connection...'). If I blast the private_key and hostname, and restart tor (a few times, plus or minus a few restarts of ubuntu)... I get a regular hostname and private key that DO work perfectly.

What am I doing wrong? I looked for whitespace, but I seem to be saving / copy-pasting okay.

  • Could you edit your question and paste the result of sudo ls -l /var/lib/tor/hidden_service? I assume that the files have wrong permissions. – Jens Kubieziel Nov 3 '14 at 10:18
  • Hi Jens. I also suspected that. Please see my next comment for those results. (Sorry about the formatting!) The ~ files are the non-generated hostname/private_keys that the Tor browser WAS able to serve. – user426364 Nov 4 '14 at 0:31
  • -rw------- 1 debian-tor debian-tor 23 Nov 3 19:29 hostname -rw------- 1 debian-tor debian-tor 23 Nov 3 19:12 hostname~ -rw------- 1 debian-tor debian-tor 891 Nov 3 19:28 private_key -rw------- 1 debian-tor debian-tor 887 Nov 2 20:00 private_key~` – user426364 Nov 4 '14 at 0:31
  • The permissions seem not correct. You start Tor Browser which runs as local user, but the files in /var/lib/tor/hidden_service belong to the Tor daemon. So changing permissions would help. However it seems better to use Directories in your Tor Browser Installation. – Jens Kubieziel Nov 4 '14 at 7:57
0

Well... I booted up today and started tor and tried to hit my onion site, and it said no-go ... so I check my hostname and it is the one I generated earlier! So I check that one ... and what do you know... it's serving!

How or why, I don't know. I am not aware of doing anything differently. Could be I had a process open that was unwittingly locking something TOR needed and a fresh reboot with ignorance being bliss was all it needed for things to go smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.