2

I use Tor Browser Bundle, and I want to use Google Search instead of Startpage:

enter image description here

But one problem is that Google constantly shifts the language depending on your exit node IP. I want to fix that by setting ?hl=en, i.e. the search URL should be:

https://www.google.com/search?hl=en&q=%s

I know how to edit search engines in Chrome, but in Tor Browser Bundle I couldn't find a way to specify a custom search engine with %s as a placeholder, nor did I find a way to edit the current search engines.

I want to set Google to always use English (?hl=en does that), how can I do that in Tor Browser Bundle?

2

I have also had this issue, but have been able to resolve it by installing a "Google US" Search Engine. You can do this by going to http://mycroftproject.com/google-search-plugins.html and choosing the third option "Google"

Mycroft Project

You should then see the option to add the Search Engine. You also have the option to set it as the default.

Add Search Engine

I hope this helps!

1

Well,if you enable cookies,you can cilck http://www.google.com/ncr, next time google will not shift the language.If not,it seems that there is no way to stop google`s auto shifting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.