Every time I try to start Vidalia, I get nothing but cold, hard, FAIL. Terminal output is as follows:


(process:4854): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
An AppArmor policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender="(null)" (inactive) interface="org.freedesktop.DBus" member="Hello" error name="(unset)" requested_reply="0" destination="org.freedesktop.DBus" (bus)

(<unknown>:4854): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)
  • Why are you using Vidalia? Recent (!) versions of Tor Browser Bundle does not ship it anymore.
    – Envite
    Dec 1, 2014 at 13:36

3 Answers 3


This bug has been confirmed. Some workarounds have been communicated, but no final solution / bugfix.

See launchpad: Bug #680192 “Vidalia was unable to start Tor. Check your setting...” and try to disable the usr.bin.vidalia AppArmor profile.

Hope this helps!

  • @threetwentysix Please accept my answer if it solved your problem or was the most helpful in finding your solution. This would also mark your question as solved.
    – marianoju
    Dec 1, 2014 at 16:37

It is already answered here and it worked for me. https://askubuntu.com/questions/449824/cant-run-vidalia-due-to-an-apparmor-policy-error

How it works: vidalia needs permission or access to something that apparmor doesn't allow. Here a site which explain the CMD: cyberciti.biz/faq/ubuntu-linux-howto-disable-apparmor-commands before running your workaround check via $ sudo apparmor_status would be a good idea and confirm afterwards that it's disabled


STOP. Do not use vidalia. It is no longer maintained or supported by TorProject and have been deprecated for a long time. Using vidalia poses unknown risks to you and if you are serious about preserving your anonymity, you should not use vidalia. Current versions of the Tor Browser Bundle show you circuit information just like vidalia did.

  • Where vidalia is marked as deprecated? I did'nt find anything about this in the TOR-Wiki.
    – user13086
    Jun 1, 2016 at 19:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .