I'm running Windows 8 and Savant 3.1. I have the DNS set to localhost:80 and it works in a normal browser.

Here's where the problem sits. I add the following to the bottom of torrc:

HiddenServiceDir C:\Users\abc\tor_service
HiddenServicePort 80

Initially, TBB would tell me that it couldn't connect to localhost.com. I reinstalled Tor and did everything again. For a short period, it just wasn't making any connection to the .onion address I was assigned, nevermind a localhost. Now it's back to the localhost.com problem:

Unable to connect
Firefox can't establish a connection to the server at www.localhost.com.

The log:

8/22/2014 23:03:53 PM.535 [NOTICE] New control connection opened.
8/22/2014 23:04:10 PM.559 [NOTICE] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later).
8/22/2014 23:05:53 PM.360 [WARN] Rejecting SOCKS request for anonymous connection to private address [scrubbed].
8/22/2014 23:18:09 PM.164 [WARN] Rejecting SOCKS request for anonymous connection to private address [scrubbed]. [20 similar message(s) suppressed in last 300 seconds]
8/22/2014 23:18:11 PM.147 [NOTICE] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.

Giving up, very sad, sounds exhausted. How can I fix the problem and finish the set up of a hidden service?

  • Sorry if this is obvious: Do you have files named 'hostname' and 'private_key' in your hidden service dir? If so, look in the 'hostname' file. That is the onion address of your hidden service. Do you have a web server running and listening on port 80 on the same machine as your Tor relay and does it accept connections from itself, i.e. from localhost? Are you a relay, i.e. do you have an OR port listening and is it reachable, i.e. port-forwarded in your router or in a dmz? – Jobiwan Aug 23 '14 at 19:56
  • Sorry I didn't make everything clear, my fault. Yes, i have hostname and private_key. When I say the Tor Browser talks about "localhost.com" that's after I enter the .onion address from the hostname file. I'm running a client, not a relay. I'm not positive if port 80 is open, I'm going to check ASAP, but when I go to my browser and go to localhost:80, it works fine. Not sure if that means much. Thanks for the help though, I appreciate it, I'll look into my port situation. – Patrick Howell ONeill Aug 24 '14 at 23:31
  • How have you defined your website in the webserver's config? Do you point it to a domain name or localhost in your webserver configuration? Both tor hidden service and your website config should point to 'localhost' on port 80 if you run both on the same computer. – IAmNoone Aug 25 '14 at 11:58
  • Your web server does not need to be reachable from the outside if you only use it as a hidden service. (So you don't need to open/forward port 80.) – Jobiwan Aug 25 '14 at 17:23
  • 2
    It sounds to me like the initial request is working, but your web server is configured to do an internal HTTP redirect to a private IP address or similar. Enable request logging in your web browser (e.g. Tor Browser / Firefox Ctrl+Shift+K), and watch the traffic. If I'm correct, you'll see one successful request then a http redirect to something invalid. You need to reconfigure your web server to use the requesting hostname instead of this. – Harry Seventyone Aug 26 '14 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.