4

I have downloaded and installed the Tor browser bundle v. 3.6.3 for Mac Website says Obfsproxy is standard included in that one - which is correct- it works in Tor Browser.

But I need to run it independently for use with OpenVPN. On Windows this is really easy to run it from the TBB, it's just a matter of running the obfsproxy.exe from the Pluggable Transports folder with the necessary parameters.

But I simply cannot seem to find an executable file called obfsproxy anywhere inside the Tor Browser application package. I am following for example this guide - link - which says it should be inside the package folder Contents/MacOS but it's not there.

How can I run obfsproxy separately from the terminal?

2 Answers 2

2

Here you go:

$ cd TorBrowser.app/Tor/PluggableTransports
$ ./obfsproxy.bin
1
  • How could I have missed that - I guess that is what happens when blind staring on another folder. I found the .bin now. I am not 100% there yet though. When i run it, I get this error: 'from Crypto.Cipher import _AES ImportError: dlopen(/Applications/TorBrowser.app/Tor/PluggableTransports/Crypto/Cipher/_AES.so, 2): no suitable image found. Did find: /Applications/TorBrowser.app/Tor/PluggableTransports/Crypto/Cipher/_AES.so: mach-o, but wrong architecture' - any idea what is going wrong?
    – Volov
    Commented Aug 11, 2014 at 1:33
0

It looks like your AES encryption library is either 32-bit on a 64-bit system or vice versa. Find out your correct architecture and re-install the Tor browser for that architecture.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .