I've installed the Tor Browser Bundle on my Mac, by downloading the package file and extracting it on my desktop. But when I try to run TBB, I get the error "Firefox is already running". I have restarted the system to clear any instances of Firefox, but I still get the error.

I have seen one reply suggesting that access rights to directories might be a problem, but I'm not sure how to correct the issue. I haven't changed any permissions in the system, I've simply followed instructions to download and run.

How can I stop this message from occurring, and thus open up Tor Browser Bundle?

  • 1
    Please open up the Activity Monitor. Are there any Firefox processes? If so, close it and try to open TBB.
    – cubecubed
    Commented Jun 19, 2014 at 3:16
  • Disable your antivirus software and try again.
    – Roya
    Commented Jun 19, 2014 at 7:38
  • Could Firefox be starting at boot, but running in the background? Maybe this is a "feature" to make it "start" faster ;)
    – mirimir
    Commented Jun 19, 2014 at 9:43
  • Thanks for the suggestions but I don't see any processes that look like firefox funning at all.
    – Steve
    Commented Jun 25, 2014 at 0:51
  • Duplicate question of: tor.stackexchange.com/questions/2159/…
    – IceQUICK
    Commented Sep 2, 2014 at 19:46

2 Answers 2


This looks like a bogus error message. At least in my case, it was caused by a file ownership problem. To diagnose, I made a copy of TorBrowser.app, and was surprised when the copy ran successfully. Renaming the original to old, and the copy to TorBrowser.app, made it so that clicking on the onion TorBrowser_en-US in the doc auto-starts the browser (but still with a Vidalia UI glitch, it thinks Tor isn't running).

So as a short-term solution, you can try that. Or this is likely cleaner, if you are comfortable in Terminal:

Navigate to the TorBrowser.app directory, and do "sudo chown -R [user-name] Data", replacing [user-name] with your own user name. This changes the owner of all the directories/files in the Data directory, which is the one Tor is trying to get access to. (If what you have is a permissions problem, you might have to reset the permissions instead, for example with "sudo chmod -R ug+w Data", to add write permissions to files and directories for user and group.)

Details of my troubleshooting are below. I haven't figured out how the new version of Tor sorts out its browser from what used to be Vidalia, so I can't give clear instructions on how to make it all work in the least possible number of steps.

To figure out why the copy worked, I looked at the directory contents of both; the non-working directory had lots of file ownership of root and another administrator, whereas the successful one, specifically in the Data subdirectory, was entirely owned by my current account. The Tor browser modifies all sorts of files in its package. (This is a bad Mac practice, please note; ~/Library/Cache or some such should be used instead.)

I also know how it happened: When I was installing the Tor update, I switched from this account to another administrator account, before the download was completed. When the download completed, it unpacked and asked me if I wanted to install, but I was in the Admin account. So when I copied over the file I gave it privileges of that account, not of the account where the software was meant to be run. (This is a bit of a funky feature, I don't think the Mac user experience works quite right in this case.)

  • Hey John G I think that has solved it. I went to find it to copy and it was in a strange place. I made a copy, removed the old version and now it seems to be running. I'm no MAC expert but I followed the general approach you outlined and it seems to work! Thank you.
    – Steve
    Commented Jul 6, 2014 at 3:11

I'm new at macverse as well but here is how I worked it; double click on the .dmg file which opens a window which shows the Tor browser globe icon, an arrow, and the applications folder icon. Grab and drag the Tor browser icon over to the applications folder icon. The bundle will then be copied over to the applications folder. After the copy is complete; select the Tor icon in the applications folder and voila! I was then able to connect.

Hope this helps....

  • yes, that worked! put the globe into the applications folder then start tor from there. voila, indeed.
    – user4839
    Commented Oct 12, 2014 at 23:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .